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Adding Custom IP to an Embedded System 
Using AXI 

Introduction  

This lab guides you through the process of adding a custom peripheral to a processor system by using 
the Create and Import Peripheral Wizard.  

Objectives  

After completing this lab, you will be able to: 

• Create a custom peripheral  
• Add the custom peripheral to your design 

• Add pin location constraints 

• Generate the hardware bitstream  

Procedure  

This lab is separated into steps that consist of general overview statements that provide information on 
the detailed instructions that follow. Follow these detailed instructions to progress through the lab. 

This lab comprises 4 primary steps: You will open the project, generate a peripheral template, create a 
peripheral, and, finally, add and connect the peripheral.  

Design Description 

You will extend the Lab 2 hardware design by creating and adding a AXI peripheral (refer to MYIP in 
Figure 1) to the system, and connecting it to the LEDs on the Nexys3 Board.  You will use the Create and 
Import Peripheral Wizard of Xilinx Platform Studio (XPS) to generate the peripheral templates.  You will 
complete the peripheral by adding LEDs interface logic in the templates.  Next, you will connect the 
peripheral to the system and add pin location constraints to connect the LEDs controller peripheral to the 
on-board LEDs.   
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Figure 1.  Design updated from previous lab 

 

General Flow for this Lab 

 

 

 

 

 

Opening the Project Step 1 

1-1. Create a lab3 folder and copy the contents of the lab2 folder into the lab3 
folder if you wish to continue with the design you created in the previous 
lab, otherwise copy the lab2 folder content from the labsolution folder into 
the lab3 folder. Open the project in XPS. 

1-1-1. If you wish to continue using the design that you created in Lab 2, create a lab3 folder in the 
c:\xup\embedded\labs directory and copy the contents from lab2 to lab3, otherwise copy the 
content of lab2 folder from the labsolution folder.  

1-1-2. Open XPS by clicking Start > All Programs > Xilinx Design Tools > ISE Design Suite 14.2 > 
EDK > Xilinx Platform Studio. 

1-1-3. Select Open project, and browse to C:\xup\embedded\labs\lab3.  

1-1-4. Click system.xmp, and click Open to open the project. 

Step 1: 
Open the 

project 

Step 2: 
Generate a 
peripheral 
template 

Step 3: 
Create a 

peripheral 

Step 4:  

Add and 
connect the 
peripheral 
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Generate a Peripheral Template Step 2 

2-1. You will use the Create/Import Peripheral Wizard to create a AXI4Lite 
interface peripheral template. 

2-1-1. In XPS, select Hardware > Create or Import Peripheral… to start the wizard.  

2-1-2. Click Next to continue to the Create and Import Peripheral Wizard flow selection.  

2-1-3. In the Select Flow panel, select Create templates for a new peripheral and click Next. 

2-1-4. Click next with the default option To an XPS project selected.  

2-1-5. Click Next and enter led_ip in the Name field, leave the default version number of 1.00.a, and 
click Next. 

 

Figure 2. Provide Core Name and Version Number 

2-1-6. Select AXI4-Lite interface and click Next.  
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Figure 3. Select the AXI4-Lite interface 

2-2. Continuing with the wizard, select User Logic S/W Register support.  Select 
only one software accessible register of 32-bit width. Generate template 
driver files. Browse to the C:\xup\embedded\labs\lab3 directory and ensure 
the structure. 

2-2-1. In the IPIF Services panel, deselect Include data phase timer, leaving User logic software 
register selected, and click Next. 

 

Figure 4.  IPIF Services Dialogue Box 

2-2-2. Click Next, accepting the default number of registers to be 1.  
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Figure 5.  User SW Registers 

2-2-3. Scroll through the IP Interconnect (IPIC) panel, which displays the default IPIC signals that are 
available for the user logic based on the previous selection.  Notice that Bus2IP_Addr, 
Bus2IP_CS, Bus2IP_RNW are not checked since the custom peripheral does not have any 
memory support. Click Next. 
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Figure 6.  IP Interconnect (IPIC) Dialog Box 

2-2-4. In the (OPTIONAL) Peripheral Simulation Support panel, leave Generate BFM simulation 
platform unchecked, and click Next. 

2-2-5. In the (OPTIONAL) Peripheral Implementation Options panel, click Generate template driver 
files to help you to implement software interface, leaving others unchecked. 

 

Figure 7.  Peripheral Implementation Options dialog box 
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2-2-6. Click Next, and you will see the summary information panel. 

 

Figure 8. Congratulations dialog box 

2-2-7. Click Finish to close the wizard. 

2-2-8. Click on IP Catalog tab in XPS and observe that LED_IP is added under USER sub-folder under 
the Project Local PCores repository. 

 

Figure 9. IP Catalog updated entry 
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The peripheral which you just added becomes part of the available cores list. Use Windows Explorer to 
browse to your project directory and ensure that the following structure has been created by the Create 
and Import Peripheral Wizard. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
Figure 10. Structure created by the Create and Import Peripheral Wizard 

Create the Peripheral Step 3 

3-1. Update the MPD file to include the led data output of the LED controller 
peripheral so the port can be connected in XPS.   

Add a port called “led” to the MPD file. 

3-1-1. Open  led_ip_v2_1_0.mpd in the pcores\led_ip_v1_00_a\data under the lab3 directory. 

3-1-2. Add following line before the S_AXI_ACLK port under the Ports section. 

 PORT LED="", DIR=O, VEC=[7:0] 

 

Figure 11. Update the MPD file for the LED Controller Peripheral 

lab3 

led_ip_v1_00_a 

data hdl 

vhdl MPD PAO 

pcores 

devl 

ipwiz.log 
ipwiz.opt 
Readme.txt 
create.cip PRJ led_ip.vhd 

user_logic.vhd 
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3-1-3. Save the file and close it. 

3-2. Create the LED controller using the appropriate HDL template files 
generated from the Create/Import peripheral wizard: led_ip.vhd and 
user_logic.vhd.  You can edit these files using a standard text editor.   

3-2-1. Open led_ip.vhd in the pcores\ led_ip_v1_00_a\hdl\vhdl directory. 

3-2-2. Add user port LED of width 8 under USER ports added here token by search for --USER ports 
added here. 

 

Figure 12. Add the user port LED 

3-2-3. Search for next  --USER and add port mapping statement, save the file and then close it. 

 

Figure 13. Add port mapping statement 

3-2-4. Open user_logic.vhd file from the vhdl directory and add LED port definition in the USER Ports 
area. 
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Figure 14. Add the LED port definition 

3-2-5. Search for next  --USER and the enter the internal signal declaration according to the figure 
below. 

 

Figure 15. Internal signal declaration for the User Logic 

3-2-6. Search for --USER logic implementation and add the following code or copy it from 
lab3_user_logic.vhd file located at c:\xup\embedded\sources directory. 

  

Figure 16. Add code 
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3-2-7. Save changes and close the user_logic.vhd 

3-2-8. Select Project > Rescan User Repositories to have the changes in effect. 

Add and Connect the Peripheral Step 4 

4-1. Add the LED to the design and connect to the AXI4Lite bus in the System 
Assembly View.  Make internal and external port connections.  Assign an 
address range to it.  Establish the LED data port as external FPGA pins. 

4-1-1. Add the led_ip core to the system by double-clicking its entry in the IP Catalog. 

4-1-2. Click Yes to add the IP instance, and OK twice to connect to the processor system using the 
default settings 

4-1-3. Select the Bus Interfaces tab in the System Assembly View and verify that the peripheral is 
connected to axi4lite_0. 

 

Figure 17.  Making bus connection 

4-1-4. Select the Ports tab, right-click the led port of the led_ip_0 instance and select Make External. 

4-1-5. Select Addresses filter and verify that the address is assigned to the led_ip instance.  

The Addresses tab should look similar to as shown.  



Adding Custom IP to an Embedded System Using AXI Lab Workbook 

 

Nexys3 3-12 www.xilinx.com/university  
 xup@xilinx.com 
 © Copyright 2012 Xilinx 
 

 Figure 18. Generate Addresses 

4-2. Modify the system.ucf file to assign external LED controller connections to 
the proper FPGA pin locations. 

4-2-1. Open the system.ucf file by double-clicking the UCF File: data\system.ucf entry under Project 
Files in the Project tab. 

4-2-2. Open the C:\xup\embedded\sources\lab3.ucf file and copy the pin assignments under the 
original ucf file.  

  

Figure 19. Adding UCF constraints 

4-2-3. Save and close the file  

4-2-4. Click on Hardware > Generate Bitstream.  

4-2-5. Close the project after Bitstream generation is done. 

We will do the software development in Lab 4 and verify the functionality in hardware. 

 

Conclusion 

The Create and Import Peripheral Wizard was used to create peripheral templates for the AXI4Lite 
interface.  Logic was added to the templates to create an LED interface peripheral.  The peripheral was 
then integrated into an existing processor system.   
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Completed MHS File 
 
# ############################################################################## 
# Created by Base System Builder Wizard for Xilinx EDK 14.2 Build EDK_P.28xd 
# Wed Sep 19 09:57:18 2012 
# Target Board:  digilent nexys3 Rev B 
# Family:    spartan6 
# Device:    xc6slx16 
# Package:   csg324 
# Speed Grade:  -3 
# ############################################################################## 
 PARAMETER VERSION = 2.1.0 
 
 
 PORT RS232_Uart_1_sout = RS232_Uart_1_sout, DIR = O 
 PORT RS232_Uart_1_sin = RS232_Uart_1_sin, DIR = I 
 PORT RESET = RESET, DIR = I, SIGIS = RST, RST_POLARITY = 1 
 PORT GCLK = GCLK, DIR = I, SIGIS = CLK, CLK_FREQ = 100000000 
 PORT dip_GPIO_IO_I_pin = dip_GPIO_IO_I, DIR = I, VEC = [7:0] 
 PORT push_GPIO_IO_I_pin = push_GPIO_IO_I, DIR = I, VEC = [3:0] 
 PORT led_ip_0_LED_pin = led_ip_0_LED, DIR = O, VEC = [7:0] 
 
 
BEGIN proc_sys_reset 
 PARAMETER INSTANCE = proc_sys_reset_0 
 PARAMETER HW_VER = 3.00.a 
 PARAMETER C_EXT_RESET_HIGH = 1 
 PORT MB_Debug_Sys_Rst = proc_sys_reset_0_MB_Debug_Sys_Rst 
 PORT Dcm_locked = proc_sys_reset_0_Dcm_locked 
 PORT MB_Reset = proc_sys_reset_0_MB_Reset 
 PORT Slowest_sync_clk = clk_100_0000MHz 
 PORT Interconnect_aresetn = proc_sys_reset_0_Interconnect_aresetn 
 PORT Ext_Reset_In = RESET 
 PORT BUS_STRUCT_RESET = proc_sys_reset_0_BUS_STRUCT_RESET 
END 
 
BEGIN lmb_v10 
 PARAMETER INSTANCE = microblaze_0_ilmb 
 PARAMETER HW_VER = 2.00.b 
 PORT SYS_RST = proc_sys_reset_0_BUS_STRUCT_RESET 
 PORT LMB_CLK = clk_100_0000MHz 
END 
 
BEGIN lmb_bram_if_cntlr 
 PARAMETER INSTANCE = microblaze_0_i_bram_ctrl 
 PARAMETER HW_VER = 3.10.a 
 PARAMETER C_BASEADDR = 0x00000000 
 PARAMETER C_HIGHADDR = 0x00003fff 
 BUS_INTERFACE SLMB = microblaze_0_ilmb 
 BUS_INTERFACE BRAM_PORT = microblaze_0_i_bram_ctrl_2_microblaze_0_bram_block 
END 
 
BEGIN lmb_v10 
 PARAMETER INSTANCE = microblaze_0_dlmb 
 PARAMETER HW_VER = 2.00.b 
 PORT SYS_RST = proc_sys_reset_0_BUS_STRUCT_RESET 
 PORT LMB_CLK = clk_100_0000MHz 
END 
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BEGIN lmb_bram_if_cntlr 
 PARAMETER INSTANCE = microblaze_0_d_bram_ctrl 
 PARAMETER HW_VER = 3.10.a 
 PARAMETER C_BASEADDR = 0x00000000 
 PARAMETER C_HIGHADDR = 0x00003fff 
 BUS_INTERFACE SLMB = microblaze_0_dlmb 
 BUS_INTERFACE BRAM_PORT = microblaze_0_d_bram_ctrl_2_microblaze_0_bram_block 
END 
 
BEGIN bram_block 
 PARAMETER INSTANCE = microblaze_0_bram_block 
 PARAMETER HW_VER = 1.00.a 
 BUS_INTERFACE PORTA = microblaze_0_i_bram_ctrl_2_microblaze_0_bram_block 
 BUS_INTERFACE PORTB = microblaze_0_d_bram_ctrl_2_microblaze_0_bram_block 
END 
 
BEGIN microblaze 
 PARAMETER INSTANCE = microblaze_0 
 PARAMETER HW_VER = 8.40.a 
 PARAMETER C_INTERCONNECT = 2 
 PARAMETER C_USE_BARREL = 1 
 PARAMETER C_USE_FPU = 0 
 PARAMETER C_DEBUG_ENABLED = 1 
 PARAMETER C_ICACHE_BASEADDR = 0X00000000 
 PARAMETER C_ICACHE_HIGHADDR = 0X3FFFFFFF 
 PARAMETER C_USE_ICACHE = 0 
 PARAMETER C_ICACHE_ALWAYS_USED = 0 
 PARAMETER C_DCACHE_BASEADDR = 0X00000000 
 PARAMETER C_DCACHE_HIGHADDR = 0X3FFFFFFF 
 PARAMETER C_USE_DCACHE = 0 
 PARAMETER C_DCACHE_ALWAYS_USED = 0 
 BUS_INTERFACE ILMB = microblaze_0_ilmb 
 BUS_INTERFACE DLMB = microblaze_0_dlmb 
 BUS_INTERFACE M_AXI_DP = axi4lite_0 
 BUS_INTERFACE DEBUG = microblaze_0_debug 
 PORT MB_RESET = proc_sys_reset_0_MB_Reset 
 PORT CLK = clk_100_0000MHz 
END 
 
BEGIN mdm 
 PARAMETER INSTANCE = debug_module 
 PARAMETER HW_VER = 2.10.a 
 PARAMETER C_INTERCONNECT = 2 
 PARAMETER C_USE_UART = 1 
 PARAMETER C_BASEADDR = 0x41400000 
 PARAMETER C_HIGHADDR = 0x4140ffff 
 BUS_INTERFACE S_AXI = axi4lite_0 
 BUS_INTERFACE MBDEBUG_0 = microblaze_0_debug 
 PORT Debug_SYS_Rst = proc_sys_reset_0_MB_Debug_Sys_Rst 
 PORT S_AXI_ACLK = clk_100_0000MHz 
END 
 
BEGIN clock_generator 
 PARAMETER INSTANCE = clock_generator_0 
 PARAMETER HW_VER = 4.03.a 
 PARAMETER C_CLKIN_FREQ = 100000000 
 PARAMETER C_CLKOUT0_FREQ = 100000000 
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 PARAMETER C_CLKOUT0_GROUP = NONE 
 PORT LOCKED = proc_sys_reset_0_Dcm_locked 
 PORT CLKOUT0 = clk_100_0000MHz 
 PORT RST = RESET 
 PORT CLKIN = GCLK 
END 
 
BEGIN axi_interconnect 
 PARAMETER INSTANCE = axi4lite_0 
 PARAMETER HW_VER = 1.06.a 
 PARAMETER C_INTERCONNECT_CONNECTIVITY_MODE = 0 
 PORT interconnect_aclk = clk_100_0000MHz 
 PORT INTERCONNECT_ARESETN = proc_sys_reset_0_Interconnect_aresetn 
END 
 
BEGIN axi_uartlite 
 PARAMETER INSTANCE = RS232_Uart_1 
 PARAMETER HW_VER = 1.02.a 
 PARAMETER C_BAUDRATE = 115200 
 PARAMETER C_DATA_BITS = 8 
 PARAMETER C_USE_PARITY = 0 
 PARAMETER C_ODD_PARITY = 1 
 PARAMETER C_BASEADDR = 0x40600000 
 PARAMETER C_HIGHADDR = 0x4060ffff 
 BUS_INTERFACE S_AXI = axi4lite_0 
 PORT S_AXI_ACLK = clk_100_0000MHz 
 PORT TX = RS232_Uart_1_sout 
 PORT RX = RS232_Uart_1_sin 
END 
 
BEGIN axi_gpio 
 PARAMETER INSTANCE = dip 
 PARAMETER HW_VER = 1.01.b 
 PARAMETER C_GPIO_WIDTH = 8 
 PARAMETER C_ALL_INPUTS = 1 
 PARAMETER C_BASEADDR = 0x40000000 
 PARAMETER C_HIGHADDR = 0x4000ffff 
 BUS_INTERFACE S_AXI = axi4lite_0 
 PORT S_AXI_ACLK = clk_100_0000MHz 
 PORT GPIO_IO_I = dip_GPIO_IO_I 
END 
 
BEGIN axi_gpio 
 PARAMETER INSTANCE = push 
 PARAMETER HW_VER = 1.01.b 
 PARAMETER C_GPIO_WIDTH = 4 
 PARAMETER C_ALL_INPUTS = 1 
 PARAMETER C_BASEADDR = 0x40040000 
 PARAMETER C_HIGHADDR = 0x4004ffff 
 BUS_INTERFACE S_AXI = axi4lite_0 
 PORT S_AXI_ACLK = clk_100_0000MHz 
 PORT GPIO_IO_I = push_GPIO_IO_I 
END 
 
BEGIN led_ip 
 PARAMETER INSTANCE = led_ip_0 
 PARAMETER HW_VER = 1.00.a 
 PARAMETER C_BASEADDR = 0x7f400000 
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 PARAMETER C_HIGHADDR = 0x7f40ffff 
 BUS_INTERFACE S_AXI = axi4lite_0 
 PORT S_AXI_ACLK = clk_100_0000MHz 
 PORT LED = led_ip_0_LED 
END 
 


