
Instructions for Using the Microsoft Word 2003 
Proceedings Paper Template 

1 Working with the Document Template 

1.1 General Information 

The template, svlnproc1104.dot, has been designed for authors preparing a paper to be 
published in one of Springer’s computer science proceedings series. The template 
supports Word 97, Word 2000, Word XP, and Word 2003. 

Predefined style formats are available for all the necessary structures to be included 
in the manuscript, and these formats can be quickly accessed using the three special 
toolbars provided with the template. 

For a detailed description of how to prepare your text, illustrations, and references, 
see the Author Guidelines for the Preparation of Contributions to Springer Computer 
Science Proceedings. 

1.2 General Working Principles 

The macros are designed to work as intuitively as possible. All commands are applied 
to the selected text. If no text is selected, a macro is applied to the current cursor posi-
tion. For example, if you have just typed your affiliation and you are going to con-
tinue with writing your abstract, do not click ‘Abstract’ before having started a new 
paragraph. Otherwise the abstract format will be applied to the address information, 
where the cursor is still positioned. 

Always type your text first and then click on the button to format it! 

1.3 Installing the Template 

• Open Word, and from the Tools menu select Macro→Security. Select ‘Medium,’ 
and then click on OK. Exit Word. 

• Copy the svlnproc1104.dot template into the directory where you want to save 
your manuscript. This will help you keep the document and its template together. If 
the document’s link to the template file is lost, the template’s tool bars and macros 
are no longer available. 

Click ‘No’ whenever you are asked to save changes to the template.  
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1.4 How to Start Writing a New Document Using the Template 

• If you have not yet started to write your paper, please open Windows Explorer, 
select the template file and click New in the file’s context menu to create a new 
document that is based on the template. 

Do not open the template out of Word via File→Open. You would edit the template 
instead of creating a new document that is based on the template. 

• You can easily find out whether a new document has been created by looking at the 
window’s title: it should read ‘Document1’ (or Document2, Document3, etc.). 

• A security warning will pop up that asks you to activate the template’s macros. 
You need to click ‘Enable’ to load and enable the template’s custom toolbars. This 
security warning will pop up every time you open the document.  

• Save the document and name it with your name and a short form of the title (e.g., 
Smith_TitleOfMyPaper.doc). 

1.5 How to Apply the Template to an Existing Document 

• Open the file you would like to format and select Tools→Templates and Add-Ins. 
Click Attach in the dialog box, navigate to your working directory, select the 
svlnproc1104.dot template, then click Open. Check the option Automatically up-
date document styles and then click OK. 

• Save the document, name it with your name and a short form of the title (e.g., 
Smith_ TitleOfMyPaper.doc) and re-open it. 

• A security warning will pop up that asks you to activate the template’s macros. 
You need to click ‘Enable’ to load and enable the template’s custom toolbars. This 
security warning will pop up every time you open the document.  

• On re-opening the document, click ‘yes’ if you are asked to adjust the page setup to 
the template’s default. This is because the page setup and some other document set-
tings cannot be updated automatically by attaching the template. They are checked, 
though, whenever you open the document. 

2 What the Toolbars Do 

The template’s toolbars consist of buttons for the available style elements in the tem-
plate. To use one of these styles, first enter text and then click the button. The style 
will then be assigned to the paragraph that currently has the cursor in it. The descrip-
tions below show you how these elements work. 

 
  

 
 

 

Fig. 1. The three toolbars 
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2.1 How to Format the Header of Your Paper 

Button Effect Description 

 Formats the 
contribution title 

• This button does not work if more than one 
paragraph is selected.  

• If a subtitle follows the title, the space after 
the paragraph is adjusted automatically. 

 
Formats a 
contribution subtitle 

• This button does not work if more than one 
paragraph is selected.  

• The spacing between the title and the subtitle 
is adjusted automatically. 

 Formats the 
authors’ names 

• This button does not work if more than one 
paragraph is selected.  

 
Formats affiliation and 
address information  

• This button sets the paragraph format for any 
affiliation information including e-mail ad-
dresses and URLs.  

• The font of e-mail addresses and URLs can 
be adjusted by using the ‘Email/URL’ but-
ton. 

 Formats e-mail addresses 
and URLs 

• This button changes the font of the current 
text selection to a typewriter font.  

• If no text is selected, the word next to the 
current cursor position is formatted with the 
typewriter font.  

 
Formats the abstract • In addition to applying the appropriate para-

graph format, the word ‘Abstract’ is added at 
the beginning of the first paragraph. 

 
Formats the keywords • This button does not work if more than one 

paragraph is selected.  
• The word ‘Keywords’ is added at the begin-

ning of the paragraph if not yet present. 
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2.2 How to Format Headings 

Button Effect Description 

 
Formats a level 1 heading
(numbered section 
heading) 

• This button does not work if more than one 
paragraph is selected. 

• If you want to create a heading without a 
number, e.g., ‘References’, simply place the 
cursor at the beginning of the text and press 
the backspace key [←]. 

 
Formats a level 2 heading
(numbered subsection 
heading) 

• This button does not work if more than one 
paragraph is selected. 

• If you want to create a heading without a 
number, simply place the cursor at the be-
ginning of the text and press the backspace 
key [←]. 

 Formats a level 3 heading 
(bold run-in heading) 

• This button does not work if more than one 
paragraph is selected. 

• If applied to selected text:  
The selection is formatted as bold run-in 
heading. 

• If applied to a paragraph:  
The first sentence, i.e., any words up to the 
first period, is formatted in bold font style as 
run-in heading. 

• If applied to an empty paragraph:  
Bold font style is applied to any text then 
typed in. Once you have finished the heading, 
you should press the ‘Standard text’ button 
to reset the character style to normal text 
again.  

 Formats a level 4 heading 
(italic run-in heading) 

• This button does not work if more than one 
paragraph is selected. 

• If applied to selected text:  
The selection is formatted as italic run-in 
heading. 

• If applied to a paragraph:  
The first sentence, i.e., any words up to the 
first period, is formatted in italic font style as 
run-in heading. 

• If applied to an empty paragraph:  
Italic font style is applied to any text then 
typed in. Once you have finished the heading, 
you should press the ‘Standard text’ button to 
reset the character style to normal text again. 
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2.3 How to Create Lists 

Button Effect Description 

 

 

Creates an unnumbered 
list with bullet items/dash 
items on the 1st level 

• This button applies a complete itemization 
scheme with multiple levels. 

• The only difference between the two buttons 
is that one starts with bullets and continues 
with dashes on the 2nd level, while the other 
starts with dashes and continues with bullets 
on the 2nd level.  

• Use the ‘list level’ buttons to set the levels 
and indents for nested lists. 

• Vertical space will only be added before and 
after a list. The spacing is adjusted automati-
cally if you select a complete block of elements 
before clicking on one of the list buttons. 

 
Creates a numbered list 
with Arabic numerals on 
its 1st level 

• Contains a numbering scheme with multiple 
levels. The 2nd level uses alphabetic charac-
ters, the 3rd level uses lower case Roman 
numerals and so on.  

• Use the ‘list level’ buttons to set the levels 
and indents of nested lists. 

• Vertical space will only be added before and 
after a list. The spacing is adjusted automati-
cally if you select a complete block of elements 
before clicking on one of the list buttons. 

 
Restarts or continues a 
numbered list 

• Only works for numbered lists. 
• If more than one paragraph is selected, the 

button only applies to the first paragraph. 

 Increases the level of an 
existing numbered or 
unnumbered list 
(increases the  
indentation) 

• Only works for text that has already been 
formatted with one of the ‘Bullet item,’ ‘Dash 
item,’ or ‘Num item’ buttons before. 

• Please only use this button with nested lists. 
• If you want to create, e.g., a numbered list 

with bulleted subitems, you should first select 
all items and click on the ‘Num item’ button. 
Then select the subitems and hit the ‘Dash 
item’ button. Finally, apply ‘List level up’ to 
the subitems. The indentation will be shifted 
to the next level and the dashes will be con-
verted to bullets since bullets represent the 
second level of the ‘Dash item’ list template. 

 Decreases the level of an 
existing numbered or 
unnumbered list 
(decreases the  
indentation) 

• Only works for text that has already been 
formatted with one of the ‘Bullet item,’ ‘Dash 
item,’ or ‘Num item’ buttons and has been 
shifted to a higher level. 

• Please only use this button with nested lists. 
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2.4 How to Format Text and Paragraphs 

Button Effect Description 

 
Formats normal text • Depending on the current selection, this but-

ton either applies the default font or it applies 
the default paragraph format:  

• If an entire paragraph (or nothing) is selected, 
and the underlying format is different from the 
standard paragraph format: The standard pa-
ragraph format is applied to the selection.  

• If an entire paragraph (or nothing) is selected, 
and the underlying format is already the stan-
dard paragraph format: The standard charac-
ter style is applied to the selection. 

• If text is selected that does not follow the 
default character style: The standard charac-
ter style is applied to the selection. 

• If text is selected that already follows the 
default character style: The standard para-
graph format is applied to the selection. 

• If you want to apply the standard paragraph 
format and remove a nonstandard character 
style, simply click on the button twice. 

• Please note that standard paragraphs are not 
indented after headings, captions, lists, etc., but 
they have a first-line indent in all other cases.  

 
Inserts vertical space  • This button adds 6 pt (2.1 mm) of vertical 

space before the selected paragraph.  

 
Removes space before 
and after the current 
selection 

• This button clears any vertical space before 
and after the selected text. 

• If space remains after the button has been 
clicked, please check the preceding and/or the 
following paragraphs for their settings. 

 Inserts a footnote • This button inserts a footnote at the current 
cursor position.  

• For remarks to the contribution title, the 
footnote character is automatically changed 
to a symbol (instead of a number). 

 Formats a reference entry • This command helps you format numbered 
reference lists.  

• The hanging indent of the reference items is 
automatically adjusted based on the total 
number of references.  

• If you prefer unnumbered references, simply 
place the cursor at the beginning of each ref-
erence item and press the backspace key [←] 
to remove the number. 
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2.5 How to Format Special Elements of Your Paper 

Button Effect Description 

 
Inserts an image from an 
external file 

• The image is always placed in an empty 
paragraph. 

• If the cursor is not in an empty paragraph 
when clicking on this button, a new para-
graph is added after the current one, and the 
image is inserted there. 

 
Formats a figure caption • In addition to applying the appropriate para-

graph format, ‘Fig. [X]’ is added at the be-
ginning of the paragraph ([X] is an automatic 
counter that is updated whenever the docu-
ment is opened). 

• This macro does not work if more than one 
paragraph is selected. 

• If the caption runs over multiple lines the 
paragraph alignment is automatically 
switched to justified. 

 
Formats a table caption • In addition to applying the appropriate para-

graph format, ‘Table [X]’ is added at the be-
ginning of the paragraph ([X] is an automatic 
counter that is updated whenever the docu-
ment is opened). 

• This macro does not work if more than one 
paragraph is selected. 

• If the caption runs over multiple lines, the 
paragraph alignment is automatically switch-
ed to justified. 

 
Formats a displayed 
equation 

• Displayed equations are always centered 
between the text margins. 

• If you want to align the equal sign in multi-
line displays, please use the alignment fea-
ture of the equation editor. 

 
Adds an equation number 
to a displayed equation 

• This button only works if the selected para-
graph was formatted with the ‘Equation’ 
button before.  

• The automatic counter that is inserted in the 
right margin is updated whenever the docu-
ment is opened. 

 Formats program listings 
and command sequences 

• Please note that the paragraph format in-
cludes tabulators every 4 mm that can help 
you adjust the indentation of code blocks. 
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3 Frequently Asked Questions 

I do not see the toolbars – what’s the problem? 

If you do not see the toolbars described in this document or if they are not functional, 
they have probably been deactivated by your current macro security settings. In this 
case, open Word and from the Tools menu select the options Macro→Security. Click 
‘Medium’ and then OK. Exit Word. 

To read more about the security levels of Microsoft Office and how they are con-
figured, please check the information available at http://office.microsoft.com/en-us/ 
office-2003-resource-kit/macro-security-levels-in-office-2003-HA001140307.aspx. 

I have attached the template to an existing document with the option ‘Automati-
cally update styles’ activated, but the document is not or not fully adjusted to the 
Springer standard. 

There are three possible reasons: First, only formatting styles that already existed in 
your original document can be updated by the template. Second, only if those styles 
were used in your original document, adjusting them can have a visible effect. Third, 
please consider that individual modifications of certain styles are usually retained, 
even if the original styles are overwritten by a new template. In all three cases, you 
should simply re-apply the appropriate styles and click the toolbar button again. 

I have formatted a text element by clicking the respective button, but some of 
the selected style’s properties were obviously not applied. 

There might be a conflict between the underlying paragraph style and some individual 
character and paragraph formatting. Most toolbar buttons change the underlying style 
only and do not generally adjust individual formatting that might be present in the 
selected text. Solution: First reset the text formatting by clicking the ‘Normal text’ 
button twice, then apply the desired style. 

The automatic numbering of sections and subsections seems to be corrupted. 

Please simply apply the H1 and H2 formats to the affected section headings or sub-
section headings once again to correct the numbering. 

I would like to use special characters in my text – how should I insert them? 

Reformatting of running text, in which special characters such as Greek letters have 
been entered via the keyboard, can cause these characters to disappear. In order to 
avoid this problem, always insert special characters to your document from the menu 
point Insert→Symbol. In the Symbol dialog box, select the required character. 

April 27, 2011 
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