OpenCores
URL https://opencores.org/ocsvn/System09/System09/trunk

Subversion Repositories System09

[/] - Rev 201

Rev

Go to most recent revision

Filtering Options

Clear current filter

Rev Log message Author Age Path
201 A copy of XSA-3S1000.ucf and System09_Xess_XSA-3S1000.vhd that have dual serial ports with no handshake. davidgb 714d 19h /
200 Started adding back in video support - VDU8 instantiated and RGBHV bits sent to Pmod JE port. davidgb 721d 17h /
199 Add in full RS-232 handshake for PmodUSBUART. davidgb 722d 18h /
198 Update UCF file to select Pmod pinout compatible with the PmodUSBUART.
To use, make sure PmodUSBUART has JP1 as "LCL". Connect the usb to the uart and open the terminal program. Test the transmission via the LED on the Pmod. Then (carefully) plug into Pmod port on Zybo.
davidgb 722d 19h /
197 Updates from John Kent:
-- 4.5 John Kent 2012-02-04 Re-arranged Rx & Tx Baud clock edge detect.
-- 4.6 John Kent 3021-01-30 Double sample RxC, TxC, and RxD with cpu_clk
-- for 125MHz Clock on Zybo Z7 board.
davidgb 729d 16h /
196 Working system boots to SBUG. Uses RS232 Pmod (no handshake) and 57600,8,N,1 (no handshake) hyperterm. davidgb 729d 16h /
195 Switched to using the UART over usb for the console port. davidgb 729d 17h /
194 Finally have a working board. davidgb 729d 17h /
193 Fixed part of the ACIA problem - the polarity of the NMI was wrong. Now get clean output but input to the ACIA is not working. Also fixed the 32k addressing davidgb 729d 21h /
192 Fixed part of the ACIA problem - the polarity of the NMI was wrong. Now get clean output but input to the ACIA is not working. davidgb 729d 21h /
191 check in file so that you do not need to generate it when running ISE in gui davidgb 730d 18h /
190 check in file so that you do not need to generate it when running ISE in gui davidgb 730d 18h /
189 Remove unused file. Created by ISE gui. davidgb 736d 12h /
188 update options to match what the ISE gui does davidgb 736d 12h /
187 Partially works. Garbage on the ACIA due to baud clock problems. davidgb 736d 17h /
186 Somewhat functional boot to SBUG. ACIA freq is wrong but sometimes works if hyperterm set to 115kBps davidgb 736d 20h /
185 Reverted back to the single-step version - something was broken davidgb 736d 22h /
184 update files to correctly produce flex9ram.vhd davidgb 736d 22h /
183 update file extensions davidgb 736d 22h /
182 Add a copy of the derived ROM contents so that you can go directly to ISE GUI without having to 'make roms' davidgb 736d 22h /
181 Add a copy of the derived ROM contents so that you can go directly to ISE GUI without having to 'make roms' davidgb 736d 22h /
180 removed xdc file since ISE 14.7 does not support XDC davidgb 736d 23h /
179 Zybo port done to the same point as the Atlys port. The hardware appears to work but the ACIA is not communicating properly. davidgb 736d 23h /
178 work on constraints file davidgb 737d 10h /
177 work on zybo port davidgb 737d 11h /
176 Don't delete system09_impact.cmd on 'clean' davidgb 737d 12h /
175 Corrected RS-232 pin connections. Cleaned up code. Removed debug code.
System boots but the baud clock must be wrong - get garbage on hyperterm.
davidgb 737d 12h /
174 Added button debounce. Single-step button. multiplex LED to show nibbles of addr and data for debug. Confirmed that CPU is reading from sys09swt.vhd SBug ROM correctly. Still need to debug ACIA output. davidgb 737d 15h /
173 Add another 16k BRAM for 56K total memory davidgb 739d 11h /
172 Add 16k RAM davidgb 739d 11h /

powered by: WebSVN 2.1.0

© copyright 1999-2023 OpenCores.org, equivalent to Oliscience, all rights reserved. OpenCores®, registered trademark.