OpenCores
URL https://opencores.org/ocsvn/System09/System09/trunk

Subversion Repositories System09

[/] [System09/] [trunk/] [rtl/] [System09_Digilent_Atlys/] [system09.ucf] - Rev 222

Rev

Details | Compare with Previous | Blame

Filtering Options

Clear current filter

Rev Log message Author Age Path
222 Added SPI master to project. Pick up Atlys rom davidgb 534d 02h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
217 Extended debug sw to show keyboard data. PS/2 keyboard now works on USB HID (you must use a PS/2 keyboard + PS/2-to-USB dongle for it to work). davidgb 537d 07h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
212 Switched from VGA output to HDMI output. davidgb 537d 10h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
209 Started adding in keyboard (not tested).
Added in green-only VGA output thru Pmod port to PmodVGA J2 port.
Started working on HDMI output
davidgb 537d 12h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
195 Switched to using the UART over usb for the console port. davidgb 603d 07h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
192 Fixed part of the ACIA problem - the polarity of the NMI was wrong. Now get clean output but input to the ACIA is not working. davidgb 603d 11h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
186 Somewhat functional boot to SBUG. ACIA freq is wrong but sometimes works if hyperterm set to 115kBps davidgb 610d 10h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
185 Reverted back to the single-step version - something was broken davidgb 610d 12h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
175 Corrected RS-232 pin connections. Cleaned up code. Removed debug code.
System boots but the baud clock must be wrong - get garbage on hyperterm.
davidgb 611d 02h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
174 Added button debounce. Single-step button. multiplex LED to show nibbles of addr and data for debug. Confirmed that CPU is reading from sys09swt.vhd SBug ROM correctly. Still need to debug ACIA output. davidgb 611d 05h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
170 More debugging. Can now see cpu_addr incrementing correctly.
Added 32k BRAM 0000-7FFF.
davidgb 613d 06h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
168 Added more pinloc info. Switched RS-232 to use PMOD connector for more h/w debug visibility. davidgb 613d 12h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
148 Check in Atlys work davidgb 857d 17h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf
141 Started work on version for Digilent Atlys SPARTAN6 board (does not build, just infrastructure to start the project) davidgb 893d 10h /System09/trunk/rtl/System09_Digilent_Atlys/system09.ucf

powered by: WebSVN 2.1.0

© copyright 1999-2022 OpenCores.org, equivalent to Oliscience, all rights reserved. OpenCores®, registered trademark.