OpenCores
URL https://opencores.org/ocsvn/minsoc/minsoc/trunk

Subversion Repositories minsoc

[/] [minsoc/] [trunk/] [utils/] - Rev 156

Rev

Go to most recent revision

Filtering Options

Clear current filter

Rev Log message Author Age Path
154 Modified to use the new autotools support in the advanced debug system v3.0. nyawn 3115d 17h /minsoc/trunk/utils/
149 Merging differences of release candidate 1.0 revision 140:148 with trunk. rfajardo 3148d 08h /minsoc/trunk/utils/
142 Updating configure.sh:
1) we don't patch the trunk version.
2) it is better to re-compile the firmwares on reconfiguration. So compiling firmwares went to configure scripts instead.

backend/xxx/configure: compiling firmwares here now.
rfajardo 3154d 07h /minsoc/trunk/utils/
141 Merging with rc-1.0 revision 140. I doubt rc-1.0 will still change much in the last days. rfajardo 3154d 07h /minsoc/trunk/utils/
135 Installation on Ubuntu-11.10 has shown that package texinfo is required to compiled GDB. This package installs the binary makeinfo. rfajardo 3162d 03h /minsoc/trunk/utils/
106 Installation script was checking the ENV variable before setting it. rfajardo 3181d 07h /minsoc/trunk/utils/
103 But the file is called gdb-6.8a.tar.bz2, so tar must be run on that name. rfajardo 3190d 22h /minsoc/trunk/utils/
102 GNU GDB FTP has renamed gdb-6.8 package to gdb-6.8a package. Uncompressed it remains gdb-6.8, so no other changes to script are necessary. rfajardo 3190d 23h /minsoc/trunk/utils/
83 minsoc-install.sh: bzip2 program was being used, but its existance on target system was not being verified. It is now. rfajardo 3243d 08h /minsoc/trunk/utils/
82 minsoc-install.sh: problems with copying the GNU Toolchain from download to tools. We uncompress the GNU Toolchain now once again to tools during the installation part. rfajardo 3246d 08h /minsoc/trunk/utils/
81 Installation script complete, nice text feedback, output logs and better execution order. rfajardo 3246d 19h /minsoc/trunk/utils/
79 minsoc-install.sh: rpath corrected.
required-cygwin-tools: updated
rfajardo 3250d 00h /minsoc/trunk/utils/
78 minsoc-install.sh: Advanced JTAG bridge compilation needs to know where the dynamic libraries are on runtime. Patching (sed) the Makefile to compile it with the rpath to the libraries (libusb/libftdi). rfajardo 3250d 00h /minsoc/trunk/utils/
77 New tool requirements for installing Icarus Verilog. rfajardo 3250d 00h /minsoc/trunk/utils/
76 Including a script allowing the installation of MinSoC and all its required tools.

It should be working for all Linuxes and Cygwin.
rfajardo 3250d 00h /minsoc/trunk/utils/
64 firmware makefiles:
-every firmware makefile has now complete dependency. This also includes dependency on files under minsoc/backend (target specific files). That means, that if some target specific header changes, the support library dependent on it will be compiled. That will always happen, even if you compile the uart firmware. In other words, if you want to use uart firmware, you can always simply compile uart by issuing make all. If anything has changed, backend files, support library, drivers, it will update everything for you.
-TODO: dependency can be automatic created by using make together with gcc. Use it instead of declaring all dependencies manually.

Makefile system for synthesis:
-the dependency for every implementation step has been checked and is working fine.
-Makefile plus support files have been moved to minsoc/syn/src
-make usage is still under syn through files generated by backend bashscripts
Backend:
-files under backend are target specific files used for the system to work
-firmware compilation
-system simulation
-system implementation
-This directory is populated by visiting one of its subdirectories and typing ./configure

backend/spartan3a_dsp_kit:
-working on FPGA

backend/spartan3e_starter_kit:
-has to be tested

backend/ml509:
-missing files have to be copied and adapted, configure script has to be copied and adapted

backend/std:
-include files necessary for firmware compilation and system configuration
-it does not include files for synthesis and is not synthesizable
rfajardo 3357d 07h /minsoc/trunk/utils/
47 Firmware updated to work with gcc-4.5. It is actually working just fine and gcc-4.5 assembly code seems a lot cleaner.

I noticed that by increasing the free stack space for the interrupt handler by 130 made the resulting firmware not work. I assume it is because 130 is not aligned 130%4 = 2 and the stack simply does not work then. Instead I'm freeing the previous 116 plus 128 (for 32 registers as mentioned by Jeremy) and it works.
rfajardo 3400d 03h /minsoc/trunk/utils/
46 Including an explanation of what has to be updated on gpio to port it smoothly to minsoc. rfajardo 3400d 08h /minsoc/trunk/utils/
45 A more stable version ConX. 3400d 23h /minsoc/trunk/utils/
44 Fixing some bugs. But it still works only in Debian/Ubuntu ConX. 3401d 00h /minsoc/trunk/utils/

1 2 Next >

Show All

powered by: WebSVN 2.1.0

© copyright 1999-2020 OpenCores.org, equivalent to Oliscience, all rights reserved. OpenCores®, registered trademark.