OpenCores
no use no use 1/1 no use no use
UDP Ethernet for Virtex-4 LX25
by acuchoh on Jul 14, 2017
acuchoh
Posts: 1
Joined: Jan 15, 2009
Last seen: Sep 18, 2017
I have implemented an Ethernet UDP communication on the Virtex-5 LX50 card (it uses the DP83865 Ethernet controller) and everything is fine. This application is based on the "Ethernet IP" project implemented by Igor Mohor.
Now I want to enable the same UDP ethernet communication on the Virtex-4 LX25 card, whose controller is the DP83847. But the following report appears in WireShark (see attached chart)

Could someone help me and tell me what I have to modify regarding the configuration in Virtex-5?
eth_v4lx25.png (106 kb)
RE: UDP Ethernet for Virtex-4 LX25
by dgisselq on Jul 14, 2017
dgisselq
Posts: 247
Joined: Feb 20, 2015
Last seen: Oct 3, 2020

Yeah, you've got a bit of a problem there, huh? I'm further going to guess that your problem comes down to the difference between the RGMII/GMII and the MII interface.

You might find the ethernet controller I put together useful. While it's not packaged as a separate core, you should find all the files you need there to use it.

I can't promise that it will work for you though, since part of what will make it work depends upon how you wish to interface with it. The core itself was built for being controlled by the ZipCPU over a wishbone B4/pipelined interface.

Dan

no use no use 1/1 no use no use
© copyright 1999-2020 OpenCores.org, equivalent to Oliscience, all rights reserved. OpenCores®, registered trademark.