OpenCores
URL https://opencores.org/ocsvn/System09/System09/trunk

Subversion Repositories System09

[/] - Rev 192

Rev

Go to most recent revision

Filtering Options

Clear current filter

Rev Log message Author Age Path
192 Fixed part of the ACIA problem - the polarity of the NMI was wrong. Now get clean output but input to the ACIA is not working. davidgb 674d 00h /
191 check in file so that you do not need to generate it when running ISE in gui davidgb 674d 21h /
190 check in file so that you do not need to generate it when running ISE in gui davidgb 674d 21h /
189 Remove unused file. Created by ISE gui. davidgb 680d 15h /
188 update options to match what the ISE gui does davidgb 680d 15h /
187 Partially works. Garbage on the ACIA due to baud clock problems. davidgb 680d 21h /
186 Somewhat functional boot to SBUG. ACIA freq is wrong but sometimes works if hyperterm set to 115kBps davidgb 681d 00h /
185 Reverted back to the single-step version - something was broken davidgb 681d 01h /
184 update files to correctly produce flex9ram.vhd davidgb 681d 01h /
183 update file extensions davidgb 681d 01h /
182 Add a copy of the derived ROM contents so that you can go directly to ISE GUI without having to 'make roms' davidgb 681d 01h /
181 Add a copy of the derived ROM contents so that you can go directly to ISE GUI without having to 'make roms' davidgb 681d 01h /
180 removed xdc file since ISE 14.7 does not support XDC davidgb 681d 02h /
179 Zybo port done to the same point as the Atlys port. The hardware appears to work but the ACIA is not communicating properly. davidgb 681d 02h /
178 work on constraints file davidgb 681d 14h /
177 work on zybo port davidgb 681d 14h /
176 Don't delete system09_impact.cmd on 'clean' davidgb 681d 15h /
175 Corrected RS-232 pin connections. Cleaned up code. Removed debug code.
System boots but the baud clock must be wrong - get garbage on hyperterm.
davidgb 681d 15h /
174 Added button debounce. Single-step button. multiplex LED to show nibbles of addr and data for debug. Confirmed that CPU is reading from sys09swt.vhd SBug ROM correctly. Still need to debug ACIA output. davidgb 681d 19h /
173 Add another 16k BRAM for 56K total memory davidgb 683d 14h /

1 2 Next >

Show All

powered by: WebSVN 2.1.0

© copyright 1999-2022 OpenCores.org, equivalent to Oliscience, all rights reserved. OpenCores®, registered trademark.