OpenCores
URL https://opencores.org/ocsvn/System09/System09/trunk

Subversion Repositories System09

[/] [System09/] [trunk/] [rtl/] [System09_Digilent_Atlys/] - Rev 212

Rev

Go to most recent revision

Filtering Options

Clear current filter

Rev Log message Author Age Path
212 Switched from VGA output to HDMI output. davidgb 549d 21h /System09/trunk/rtl/System09_Digilent_Atlys/
209 Started adding in keyboard (not tested).
Added in green-only VGA output thru Pmod port to PmodVGA J2 port.
Started working on HDMI output
davidgb 549d 23h /System09/trunk/rtl/System09_Digilent_Atlys/
195 Switched to using the UART over usb for the console port. davidgb 615d 18h /System09/trunk/rtl/System09_Digilent_Atlys/
194 Finally have a working board. davidgb 615d 18h /System09/trunk/rtl/System09_Digilent_Atlys/
192 Fixed part of the ACIA problem - the polarity of the NMI was wrong. Now get clean output but input to the ACIA is not working. davidgb 615d 22h /System09/trunk/rtl/System09_Digilent_Atlys/
189 Remove unused file. Created by ISE gui. davidgb 622d 13h /System09/trunk/rtl/System09_Digilent_Atlys/
188 update options to match what the ISE gui does davidgb 622d 13h /System09/trunk/rtl/System09_Digilent_Atlys/
186 Somewhat functional boot to SBUG. ACIA freq is wrong but sometimes works if hyperterm set to 115kBps davidgb 622d 22h /System09/trunk/rtl/System09_Digilent_Atlys/
185 Reverted back to the single-step version - something was broken davidgb 622d 23h /System09/trunk/rtl/System09_Digilent_Atlys/
176 Don't delete system09_impact.cmd on 'clean' davidgb 623d 13h /System09/trunk/rtl/System09_Digilent_Atlys/
175 Corrected RS-232 pin connections. Cleaned up code. Removed debug code.
System boots but the baud clock must be wrong - get garbage on hyperterm.
davidgb 623d 13h /System09/trunk/rtl/System09_Digilent_Atlys/
174 Added button debounce. Single-step button. multiplex LED to show nibbles of addr and data for debug. Confirmed that CPU is reading from sys09swt.vhd SBug ROM correctly. Still need to debug ACIA output. davidgb 623d 17h /System09/trunk/rtl/System09_Digilent_Atlys/
173 Add another 16k BRAM for 56K total memory davidgb 625d 12h /System09/trunk/rtl/System09_Digilent_Atlys/
171 remove old Xess files davidgb 625d 18h /System09/trunk/rtl/System09_Digilent_Atlys/
170 More debugging. Can now see cpu_addr incrementing correctly.
Added 32k BRAM 0000-7FFF.
davidgb 625d 18h /System09/trunk/rtl/System09_Digilent_Atlys/
169 Fixed clock connection and reset button polarity. Debug LED counting and cpu_clk now indicates some activity. davidgb 625d 23h /System09/trunk/rtl/System09_Digilent_Atlys/
168 Added more pinloc info. Switched RS-232 to use PMOD connector for more h/w debug visibility. davidgb 625d 23h /System09/trunk/rtl/System09_Digilent_Atlys/
163 more directory cleanup davidgb 626d 13h /System09/trunk/rtl/System09_Digilent_Atlys/
162 stripped down to most basic system (no vdu, keyboard, sdram, ide, etc). davidgb 626d 13h /System09/trunk/rtl/System09_Digilent_Atlys/
161 more work on makefile for atlys davidgb 626d 18h /System09/trunk/rtl/System09_Digilent_Atlys/

1 2 Next >

Show All

powered by: WebSVN 2.1.0

© copyright 1999-2022 OpenCores.org, equivalent to Oliscience, all rights reserved. OpenCores®, registered trademark.