OpenCores

Fade - Light L3 Ethernet protocol for transmission of data from FPGA to embedded PC :: Bugtracker

Issue List
Transmission sometimes is stopped with "Incorrect set number in received packet! " messages #1
Closed wzab opened this issue about 6 years ago— assigned to: wzabRequest
wzab commented about 6 years ago

When running long transmission tests at high speed multi-core CPU, sometimes transmission got broken, and in log files "Incorrect set number in received packet!" appeared.

wzab was assigned about 6 years ago
wzab commented about 6 years ago

The problem was caused by error in incrementing of acknowledged packet number. This variable shoud be incremented modulo SET_NUMBER_MASK.

Error is fixed in version 9 in SVN.

wzab closed this about 6 years ago