OpenCores
Issue List
Dead State #6
Closed HanySalah opened this issue almost 6 years ago
HanySalah commented almost 6 years ago

Force wrong prefix on the DUT serial input port let it be in unexpected state and can't respond to any valid command after that

smuller commented almost 6 years ago

Could you give some details? Or a short test bench to show the problem?

motilito was assigned almost 6 years ago
motilito commented almost 6 years ago

This is not a bug but the expected behavior. In text mode protocol you may reset the parser state machine by sending a new line / carriage return character. Simply pressing the enter key in a terminal will do the job. Binary mode is much less protected but sending 256 zeros and then sending a NOP command with ACK request should return the state machine to IDLE. The sequence of NOP with ACK may neet to be re-requested with a leading zero to solve the two possibilities of IDLE or MAIN_BIN_CMD states. Moti

motilito closed this over 4 years ago

Assignee
motilito
Labels
Bug